1

Call recording is working fine but the only issue is that my voice is doubled (Like it's taking input from two sources: eg, two mics).
The other voice is clear.
I am using a rooted Redmi Note 4 with Pixel Experience ROM Pie 9.0

Thanks in advance!

2

Now that you have rooted your Xiaomi Redmi Note 4 Android 9 Pie, please use these settings to record calls:

- Record Mode: Alsa
- Alsa Device: Device0
- Alsa Bits: 16 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto
- Fix Recording Issues - Change Audio Controls: Yes
- Fix Recording Issues - Change Audio Driver: No
- Fix Recording Issues - Start Input Stream: No

It should work well.

3

I tried this. During calls it says "Recording failed, please change "Alsa Device" in settings and try again"

I tried all Alsa devices but no luck.

What settings should I keep for Tune Audio Effect and Tune Audio Route?

4

It says "Recording failed, please change "Alsa Device" in settings and try again". I tried all Alsa devices but no luck.
=> You are using another recorder blocking Boldbeast working, or you are using a Voice Assistant like OK Google or Xiaomi Virtual Assistant etc blocking Boldbeast working. You should disable them. Please see [001] in this page http://www.boldbeast.com/android/call_r … oting.html to know how to fix it.

What settings should I keep for Tune Audio Effect and Tune Audio Route?
=> They don't matter.

5

Thanks for the prompt reply.

Voice Assistant is off. No other recording apps. Not sure how to check if some other app is recording. I checked the microphone permission, no other app has it except Google, Phone and Boldbeast.

Apart from that, what are the possible reasons for my voice getting doubled/echoed?

Thanks

6

Can you please click "Call Settings - Fix Recording Issues - Ask New Parameters" in Boldbeast Recorder to send log files to me? Let us have a look at them and see what happened in your phone. Thanks.


UPDATE
I checked your log files. You are using the Alsa Device1 to recording calls, this is the reason why it fails. Please use Alsa Device0, it works very well, recorded calls are crystal clear in both sides.

7 (edited by anonys Yesterday 18:18:56)

Thanks, it worked! No more double voice, no more echos.

These are the settings I am using:

- Record Mode: Alsa
- Alsa Device: Device0
- Alsa Bits: 16 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto
- Fix Recording Issues - Change Audio Controls: Yes
- Fix Recording Issues - Change Audio Driver: No
- Fix Recording Issues - Start Input Stream: No