1

Hi,

on my main phone I installed Boldbeast Recorder and made almost everything working.

Wireless Headphones work perfectly!
But on the normal microphone (regular call) my own voice has an Echo. The faster I speak the more you can hear it. Its a mini-delay.



*Installed app from website
*flashed magisk module
*enabled root options

Record Mode1 (Alsa Mode Root doesnt work at all, with no other settings)

Auto Switch Speaker On (NO)
(when its on YES, I cant use wireless headphones, so NO)

Noise Suppress (NO)
(didnt change anything yes or no)

Tune Audio Effect (NO)
(didnt change anything yes or no)

Change Audio Controls (YES)

Start Input Stream (NO)
(didnt change anything yes or no)



I know I have 2 threads open, but those are my 2 work phones and as soon as the apps work I will buy the apps.
Would pay even more than 10 if everything works, this app is soooo necessary for many people!!

Thank you for the help.

2

Please use these settings to record calls:

- Record Mode: Alsa
- File Sampling Rate: Auto
- Alsa Device: Device0
- Alsa Sampling Rate: Auto
- Fix Recording Issues - Change Audio Controls: Yes

At first please disable OK Google to avoid conflicts.

3

At first I got errors "Alsa device cant record....", but then I disabled Google App (in App settings force stop/disable), and then it worked.

I am 90% happy, but there is a weird clicking sound now over the whole conversation - my voice and the caller voice.
(Changing sampling rate did nothing. Didnt even change the quality of the voices, so I left it at auto.)

The clicking sound is only there when I am using the phone mic, its not there when using Bluetooth Headphones.

4 (edited by livin Yesterday 06:58:23)

I just realized that while the Magisk module is enabled, my camera doesn't work.

Can't connect to camera - Error

Thats a big problem actually. Is the Magisk module necessary?

5

I am 90% happy, but there is a weird clicking sound now over the whole conversation
=> Please set following settings:
Call Settings - Alsa Sampling Rate: 48000
Call Settings - File Sampling Rate: 48000
Now the sound should be crystal clear.

I just realized that while the Magisk module is enabled, my camera doesn't work. Is the Magisk module necessary?
=> Because you are using the Alsa record mode, the CallRecordingFix Magisk module is not necessary, so you can uninstall it. And, I'm afraid your camera problem has nothing to do with the CallRecordingFix module. Even if you uninstall the module you'll find your camera problem is still there. Why? Because you installed another magisk module that wrongly changed selinux policies in your phone. You should find out that module and uninstall it.

6 (edited by livin Yesterday 08:18:57)

boldbeast wrote:

I just realized that while the Magisk module is enabled, my camera doesn't work. Is the Magisk module necessary?
=> Because you are using the Alsa record mode, the CallRecordingFix Magisk module is not necessary, so you can uninstall it. And, I'm afraid your camera problem has nothing to do with the CallRecordingFix module. Even if you uninstall the module you'll find your camera problem is still there. Why? Because you installed another magisk module that wrongly changed selinux policies in your phone. You should find out that module and uninstall it.


Just to clarify, I tried enabling and disabling the CallRecordingFix Module in Magisk.
It was the only reason my camera app wasnt working anymore.
I dont understand the tech behind that problem, but I can when I disable the module the module, reboot - the camera works; enable the module, reboot - the camera doesnt work.



I disabled the CallRecordingFix Module.
But sadly the settings didnt fix the problem while using the buildin mic. Its still a periodical clicking sound.
The other side doesnt hear any clicking sounds, so its only on the recorder.

On wireless headphones its also not there. Still works perfectly.

7

Please try to set following settings:

Call Settings - Alsa Sampling Rate: 8000, 16000, 44100
Call Settings - File Sampling Rate: 8000, 16000, 44100

Keep both of them same, and test 8000, 16000, 44100 one by one. One of them will make recordings perfect.
How about it?

8 (edited by livin Yesterday 11:32:12)

The right Sampling rate was 8000!
Now everything works perfectly. Phone mic and wireless headphones. Crystal clear sound both ways.
Thank you so much!



Here again all the settings that were necessary (for myself and others as reference).

- Root System
- Install Boldbeast Recorder
- Disable Ok Google (Google App forced stop + disable)


Settings -> Call Settings:
- Record Mode: Alsa Mode (Root)
- File Sampling Rate: 8000
- Alsa Device: Device0
- Alsa Sampling Rate: 8000

Settings -> Call Settings -> Fix Recording Issues:
- Enable Root Options
- Change Audio Controls: YES