Hi there,

I have akquired the Boldbeast Pro version (actually now three times: I had it on the old phone, then 2 times on the new phone, because I couldn't figure out how to transfer the licence...).

● I switched to Asus Zenfone 6. I tried all "record mode" options (mode 1 ... through mode 7 + mode 11 ... through 14). None worked.

● I tried to record a memo: does not work.

● Asus Zenfone 6 comes with a preinstalled app called "Audiorecorder" which can't be uninstalled. But I revoked all permissisions (mic, storage, telephone).

● I did a search here in the BBS "Zenfone 6" - could not find a solution.

Any idea? Is the support reading this BBS or only other customers?



Some phones have the call recording feature disabled, as a result they can't record calls well, so root is needed to fix it.
But all phones have no problem to record memo. You said "memo recording fails", it's strange. Can you please click "Call Settings - Fix Recording Issues - Ask New Parameters" in Boldbeast Recorder to send log files to me? Let me have a look at them and see what happened in your phone. Thanks.


Hi Admin,

thanks for your reply. It seems there was some issue with the rights to save files in the phone. Now memo is working. That is an important step. Next (and more) important step is to get the calls recorded.

I tried again every single record modes (1... 14).

Some modes do record the calls. But: in none of them one can hear any sound.

BTW: I also activated the option "Ask before save". It did ask with modes 1, 5, 7, 12, 13, 14. (But as I said: all without any sound in the files).

Andy idea what might be wrong?

Thanks in advance.


pxpa wrote:

without any sound in the files

Android 10?
Please install Boldbeast Recorder V12.9, and
- Tap "Settings - System - Accessibility" in your phone (not in Boldbeast), enable Boldbeast Call Recorder on the screen.
- In Boldbeast Recorder use Record Mode 12 to record calls.
How about it?


boldbeast wrote:

How about it?

Hello Admn,

Thanks so much, it works!! (Yes, Android 10)

I have to admit that I have some concern about this configuration though. Because Android informs me that with this setting the app "can read all content on the screen..." + "It can track your interactions with an app ... and interact with apps on your behalf"
This seems to be really HUGE rights, right? If anybody does his banking with his cellphone the app can track e.g. all the credentials or even control apps "on my behalf"? Would there be a possibility to limit those rights and yet be able to use the app?

Thanks in advance!


pxpa wrote:
boldbeast wrote:

How about it?

Hello Admn,

Thanks so much, it works!! (Yes, Android 10)

Mhm... I was too fast with my joy. It does record only a few seconds and very unreliable. I tried around, but so far couldn't figure it out.

Is there a manual, where all the options are explained systematically?

Thanks in advance!


1. On the "Settings - System - Accessibility" screen, you must enable the Boldbeast Call Recorder accessibility service. This is the key to bypass the new limit added into Android 10 by Google. If you don't do so, your recordings will be totally silent without doubt.

2. When you enable the accessibility service, Android will display the message "Boldbeast Recorder will observe text that you type includes personal data such as credit card numbers and passwords". Actually Boldbeast Recorder will not observe any text that you type. The app just needs the accessibility service being enabled to bypass the call recording limit.

3. You said "unreliable". I guess you disabled the Boldbeast Call Recorder accessibility service because the above "observe text" concern. Please enable the service, it will work again. Actually it's super reliable.

But, who knows the app is not really "observing my text and stealing my data"?
(1) The app is publicly published, every Android software engineer and safe specialist can reverse engineer it and check it.
(2) Boldbeast Software Inc. is a Canada company. Canada has strict laws related to privacy. If we steal users' data, we'll be put in prison.
No, we don't hurt users, we don't hurt ourselves, we don't do bad things.


Hello Admin,

thanks a lot, I appreciate your efforts very much!

I tried as you said, but somehow I still have mixed results. In my own tests it works, but with real calls from others it does not. Which is strange.

Could it have s.th. to do with the settings at Incoming Calls > Auto detect Answered State (I have it activated) and the "Auto Detect Max Time (100 sec) or "Restart Recording Upon Answered" (I have it activated)?


PS: I also appreciated your explanations in your last chapter! (actually, honestly said I was doubtful first about the trustworthness of the company, because the boldbeaster website at first sight seems not even to deliver any address or contact page, but then I found an address in small grey fonts on green background at the footer, quite difficult to find and to read at least on my monitor ;-))


- when you make an outgoing call, recordings are good.
- when you receive an incoming call, you said "it does not". Do you mean "recordings were not saved", or "recordings were saved but silent"?


Im meant "recordings were not saved". But now I re-checked and saw that the "Boldbeast Call Recorder accessibility service" was disabled again (although I can't remember that I did disable that). In my test after re-enabling it and calling myself from another telephone line it worked. - If ever it might not be stable I'd be back here, but as for now I thank you very much for your patentient support!


You said "recordings were not saved", that's because the system killed the app.
Glad you finally found the reason. With the accessibility service enabled the app will not be killed, so it's super stable.

12 (edited by pxpa 2020-01-18 19:53:06)


unfortunately still problems. I got a call. When it ended after 3 minutes I was asked whether I want to save it or not. So far so good, and I clicked "yes". But it did only record one second of the 3 minutes. Any idea?

I did re-check: accessibility service is still enabeld.

Had another phonecall. It DID record all the time, the red button was big, and when asking me whether to save or not it showed the length of the call with 20 minutes. But after saving there were only 4 seconds saved, and the timestamp of the file shows the beginning of the recording, not the END of it. Any idea?


Previously I guessed it's a battery related problem. I asked you to send log files to me, but you didn't do so. Another user sent log files to me and I checked them.

The problem is, another recorder is blocking Boldbeast working. Please uninstall all other recorders, then Boldbeast works at once.


I went through all my apps. There is no other Recorder (There was a pre installed app "Audiorecorder", which is not de-installable, but I deactivated it).

I also made sure what you suggested about battery, and also about the accessibilty setup.

I appreciate the offer to send you a logfile. But I checked this ZIP-file. It includes many files with tons of tons of tons of information about the content of my smartphone. I just cannot give all these data out of my hands, in these days of cyber-INsecurity. Maybe if there is especially ONE of all those files, which contains the crucial information and I could send you this file, after reading across the content myself?

Maybe the Zenfone 6 (with Android 10) does not work together with Boldbeast?


So I don't know what made it not working in your phone.
Boldbeast Recorder works great for other Asus Zenfone 6 Android 10 users.