1

Apparently Boldbeast can't record calls on this phone.
I am told by Boldbeast that callservices already records the calls... Any ideas?

2

What "callservices"?

3

boldbeast wrote:

What "callservices"?

I honestly don't know.
I have grabbed a couple of screenshots with the messages I get:
boldbeast.recorder.jpg
android.incallui.jpg

4

There is an app named "Phone Services" in your phone that was recording the call, that blocked Boldbeast to record the call.
You should disable that app to record calls, so that Boldbeast can do its jobs.

5

boldbeast wrote:

There is an app named "Phone Services" in your phone that was recording the call, that blocked Boldbeast to record the call.
You should disable that app to record calls, so that Boldbeast can do its jobs.

I found it but it can't be disabled.
I can force close it, but it autostarts again.
Apparently it's a system process, as it's only visible in the apps list when system processes are set to be visible.

6

You can revoke the "Microphone" permission from it, and then test again.
How about it?

7

boldbeast wrote:

You can revoke the "Microphone" permission from it, and then test again.
How about it?

I'd wish I could... All permissions for that app are locked/ghosted out.

8

So the "Phone Services" automatically records your calls. Usually there are settings to disable the behavior,please check your phone settings.
If needed please ask Huawei "How to disable the Phone Services to automatically record my calls?"


UPDATE
The message your phone displayed "Phone Service is currently recording audio, Boldbeast Recorder can't record the call" is a wrong information. Other Huawei Android 10 phones display the message as "Phone Service is running, Boldbeast Recorder can't record the call".

Basically, this is a new limit added into Android 10 by Google to disable the call recording feature. Huawei doesn't display the message accurately.

The good news is, Boldbeast Recorder can bypass the limit. Please:
- Confirm you are running Boldbeast Recorder V12.9 or a newer version.
- In Boldbeast Recorder tap "Call Settings - Manually Record Calls - Hotkey" to open the Accessibility settings screen, enable Boldbeast Call Recorder accessibility service on the screen. 
- In Boldbeast Recorder use Record Mode 12 to record calls.
Now your Android 10 phone can record calls .

9 (edited by SnowmanDK 2020-02-06 06:45:06)

A reset to default settings did change Record Mode to 12, and I can confirm that it does record calls now.
Sadly the other end is very low :/

10

SnowmanDK wrote:

A reset to default settings did change Record Mode to 12, and I can confirm that it does record calls now.
Sadly the other end is very low :/

So you have successfully bypassed the first limit. At this stage most Huawei Android 10 phones work great, recordings are loud and clear in both sides.
However some Huawei Android 10 phones in some market areas still have the second limit inside, and it can't be bypassed. This is the reason why "my voice is good but the caller's voice is weak in recordings". In this case you should root the phone, then Boldbeast Recorder can fix it.

11

Sadly I have a few very important apps that refuse to run on rooted devices (tried it before), so I guess I have to wait end HOPE they change the limitation. But thanks so far :)

12

Update: I have noticed that Boldbeast throws the microphone error when trying to put the call on the speaker, but it records (very low at the other end) when speaker is off.

13

I have noticed that Boldbeast throws the microphone error when trying to put the call on the speaker, but it records
=> This message is not displayed by Boldbeast, instead it is displayed by the system. Obviously this message is not necessary. Maybe you can disable it somewhere in system settings (not in Boldbeast).

very low at the other end when speaker is off.
=> This is exactly the problem in the post #9 above.