1 (edited by nadieaqui 2021-03-03 17:06:08)

[Update 2021-02-25] works with Magisk 22.0 (22000) (18)
[Update 2021-02-23] works with BoldBeast 14.7 also
[Update 2021-02-15]

Working: bluetooth headset, wired headset, speaker, and phone

Acknowledgemnet: @boldbeast and @pathrikumark for suggestions and things to try

Recommendation: Buy BoldBeast Pro -- Benefits
1) Auto Recording -- so you don't miss recording a call
2) Support the Developer[s]
3) Potential for new features/GUI changes.

Note: NLL ACR, Cube Recorder, and Skvalex Recorder did not work for me
Note: I used Magisk to root Pixel 3a XL

PreConditions:
1) Disable Google Assistant (aks Ok Google)
2) Disable  "Setting->Accessibility->Live Caption"

My configuration:

Pixel 3a XL, Android 11 (Build RQ1A.210105.002)

Magisk Manager: 22.0 (22000)(18), 8.07 (4834)(15)
Magisk: 22.0 (22000), 21.4 (21400)

BoldBeast: 14.7, 14.6, 14.5
- Call Settings->Fix Recording Issues-> Install CallRecordingFix Module
- Call Settings->Fix Recording Issues->Change Audio Controls: Checked
- Call Settings->Fix Recording Issues->Start Input Stream: UnChecked
- Call Settings->Record Mode->Alsa2 Mode (Root)
- Call Settings->File Sampling Rate: 16000


Troubleshooting - Slow Motion Recording:
Cause: Something (Google Assistant, some app) is interfering will the recording.

1) You have multiple Google Accounts on Phone -- Google Assistant is per account:
- Delete all Google accounts.
- Restart phone.
- Add a Google Account.
- Check Google Assistant is disable in account.
- Test BoldBeast.
- repeat: add account, disable, test

2) Disable Google Assistant:
- start Google App
- select Account (Top Right)
- select More (bottom right)
- Setting->Google Assistant->General->Google Assistant: toggle off

3) Disable Google Assistant access on Headphones (reminder: if mutiple google accounts, do this for all accounts)
- start Google App
- select Account (Top Right)
- select More (bottom right)
- Setting->Voice->Bluetooth audio recording: toggle off
- Setting->Voice->Allow Bluetooth requests with device locked: toggle off
- Setting->Voice->Allow wired headset requests with device locked: toggle off

4) Disable  "Setting->Accessibility->Live Caption"

5) Reset to default settings, and reconfig
- Settings->Set Default Settings
- Power Off Phone (not restart)
- Power On Phone
- Use configuration listed above
- Power Off Phone (not restart)
- Power On Phone

2

Thanks for sharing the information. Glad it works.