1 (edited by barra 2020-11-23 23:54:52)

Hello! I'm using the Xiaomi Poco X3 NFC. Have run these steps:

- In Boldbeast Recorder tap "Call Settings - Manually Record Calls - Hotkey" to open the Accessibility settings screen, enable Boldbeast Call Recorder accessibility service on the screen.

- In Boldbeast Recorder use Record Mode 12 to record calls.

First the recordings remained completely silent. After switching the Tune Audio Effect on calls are recorded, however with a very low volume on the other end, and with me being way too loud in comparison.

Plus, if I use the volume buttons, only the volume indicator changes, but not the volume. Neither can I switch the speaker on or off.

Hope this can be fixed without rooting the phone. It's a hopeful sign at any rate that there is something being recorded at all. Was already about to give up. ;)

Edit: Should have better put this into the call recording thread, sorry. Maybe you can attach my question there?

2

1. If your voice is good but the voice of your friend is weak or silent in recordings, you should
- Switch on the loudspeaker during a call, so Boldbeast can record the call on both sides normally. Or
- Root the phone, so Boldbeast can fix it completely to record calls on both sides perfectly without switching on the loudspeaker.


2. A few phones have the problem "if I enable the Tune Audio Effect option in Boldbeast, I can't change the call volume during the call." In this case please:
- Disable the option "Tune Audio Effect" in Boldbeast.
- Make a call and during the call set the call volume correctly, then hang up the call.
- Enable the option "Tune Audio Effect" in Boldbeast.
- Future calls will use the volume you set above. During a call the call volume can't be changed.

This solution is not very good, sorry for that. But I'm afraid this is the best one without root.
However if you root the phone, Boldbeast can fix the problem completely.

3

Thank you, @boldbeast. Rooting is no option. Gonna try out the measures recommended by you.

Obviously, due to the restrictions of Android 10, it's no longer possible to record directly from the sound chip, but only the speaker's sound via mic, right? Which would make it even impossible to record calls when using a headset.

Well, any recording is better than no recording at all, but still a shame. That feature was so very useful. Respectively is, if it works. :) Sending in the hardware log files won't help anything about this issue, will it?

4

barra wrote:

Sending in the hardware log files won't help anything about this issue, will it?

In this case it has no help.

5

Ok. Do you think there is a chance, that it will work under Android 11 again? Not very possible, huh?

If anyone finds out preferences to make it work as perfect as possible without root, feel welcome to share it. :)

6

barra wrote:

Do you think there is a chance, that it will work under Android 11 again?

It's possible.
Some users found their phones work well at first, but bad after upgrade the Android system, or on the contrary.

7

The good news is: I got it working in the meantime. Granted, without displaying the number, but nevermind. And without the speakers turned on the sound level is way too low to understand the caller's voice in the recording. So it works only for calls from home. Anyway, this is much better than nothing.

If there wasn't one issue unsolved: When doing or receiving calls, the record button often does not appear, so there's no chance to record the call. Opening the boldbeast app and pressing the button there does not solve the problem, since this does only record a completely silent voice memo.

My makeshift solution to bypass this problem is to do like follows: Before doing a call I press the button and record a short memo of some seconds. After finishing this I can make a call and the recording button appears in the phone call like it is supposed to. When I press it then, the call gets recorded.

Not the most convenient method, but it works. But this goes only for outgoing calls. The only possibility to record incoming calls would be to finish it, then "waking up" the boldbeast app by doing a short memo and afterwards return the call. Not feasible for everyday business.

By the way, in the options there's actually chosen to record all calls automatically, but that does not work out. Have to record them "by hand".

I'm using mode 12. It was the only combination with which it was possible to record calls at all.

So any advice what I could do to fix this issue and get my phone being alert even for incoming calls without being dependent on the "memo trick"? Or, even better, make it record all calls by itself? Any hint that's worth a try would be appreciated.

8

Your phone killed the app constantly, and this is the reason why it doesn't work.
Please see [002] in this page http://www.boldbeast.com/android/call_r … oting.html to know how to fix it.