OnePlus 7 Pro GM1913 running Oxygen OS 10.0.5 (Android 10)

Rooted with Magisk

CallRecordingFix Module installed correctly

All volumes + voices etc can be heard and everything works perfectly fine. EXCEPT:

Everytime I start recording, the recorder is perfectly fine until it hits exactly 0:30 (30 seconds) and sometimes goes to 0:31 then it automatically stops recording, no error or anything else follows. It simply just stops recording and saves the file as normal. I've tried recording with my phone off, staying inside the app at all times, staying inside my VOIP app etc, but nothing has worked.

So in order to record I must wait those 30 seconds and keep pressing the rec button over and over every 30 sec, as you can imagine it's quite tedious. I tried switching to VIDEO VOIP and the same thing happens, except it always stops at 0:10 sometimes 0:11.


You are using the VoIP Recorder.
With the free version everyday you can record 2 full recordings without limit, and more recordings limited to 30 seconds each.
Please open the "About" screen in the app, tap the Subscribe button to upgrade to the pro version, so that recordings will no longer be limited.