Boldbeast Recorder displays "Cannot record calls because of SELinux. Please change Record Mode in settings and try again, or visit the developer web site to know how to remove the SELinux limit.", what's the matter?

You are using Record Mode 21,22,23,24,31,32,33,34 but it can't work because of the limit of SELinux. Please:
- install the SELinuxModeChanger app (please google it to download and install it).
- use SELinuxModeChanger to set SELinux to "Permissive" to remove the limit.
- now you can use Record Mode 21,22,23,24,31,32,33,34.

SELinux is a Linux kernel module that provides a mechanism for supporting access control policies to make the system more secure. If possible you should remain SELinux enforcing. But this may make many apps that need root access not working, for example it may prevent Boldbeast Recorder fixing recording problems in some phones.

- You need to care about SELinux only if your system is Android 5.0 up (some Samsung phones are Android 4.3 up).
- Some phones don't need to change SELinux even if the system is Android 5.0 up (Samsung 4.3 up), because the SELinux policies don't prevent Boldbeast Recorder work. It's different from phone to phone.

Record Mode 1,2,3,4,5,6,7,11,12,13,14 in Boldbeast Recorder have nothing to do with SELinux, so they are preferred.
Record Mode 21,22,23,24,31,32,33,34 are very powerful, some phones must use them to record calls in two directions. In this case if they don't work you should set SELinux to permissive to make them work.


If you don't want to install the SELinuxModeChanger app, you can set selinux to permissive temporarily this way:

- from Google Play install the Terminal Emulator app.
- open Terminal Emulator.
- input "su" + ENTER key.
- input "setenforce 0" + ENTER key.
- input "exit" + ENTER key.

Now SELinux is permissive.

- After reboot SELinux is enforcing again. This is just a temporary way.
- It doesn't work for Samsung phones because of Samsung KNOX.


Why does Boldbeast Recorder not add a "set SELinux to Permissive" option inside the app?

In Boldbeast Recorder V7.5, V7.6 and V7.7 we do have the "set SELinux to Permissive" option inside the app, it's very convenient for users. But we removed this option from V7.8, because Google Play doesn't allow apps have this feature.


I have a Samsung S4, now even rooted.
In the info in blod beast it says it supports the S4. And it's the bluetooth call recording especially that got messed up in kitkat I was using an app called "Smart Auto Call Recorder" in 4.3(Jellybean) and everything worked good. And when I try the different root record modes it gives me the message "Cannot record calls because of SELinux. Please change Record Mode in settings and try again, or visit the developer web site to know how to remove the SELinux limit."  Is there any way to fix it?
/kind regards


For Samsung phones you should uninstall KNOX, then SELinuxModeChanger works.

Actually, Galaxy S4 doesn't need to disable selinux. Most Galaxy variants even don't need to root the phone, look here: Galaxy S4 Call Recorder

6 (edited by fula5 2017-01-24 13:08:04)

The program work Fine until a couple of weeks ago. I think it was update and from there it give this error.  Nexus 5 (rooted) (récord mode 21) with full versión install  9.1GP.   Android 6.0.1.  I Will appreciate a solution.


The post #1 in this topic is the solution.
However Nexus 5 can use other Record Modes instead of Record Mode 21, so you can avoid the problem. More info: Nexus 5 Call Recorder