1

Motorola One Power Android 9.0 disabled the call recording feature. This is the reason why your own voice is good but the caller's voice is very weak in recordings. No matter what recorder you are using in the market the result is the same. You can test and confirm this fact. Boldbeast Recorder can fix the problem perfectly if you root the phone. Without root there will be no solution in the world unfortunately.

After root the phone please use these settings to record calls:

- Record Mode: Alsa
- Alsa Device: Auto
- Alsa Bits: 16 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto
- Fix Recording Issues - Change Audio Controls: Yes
- Fix Recording Issues - Change Audio Driver: No
- Fix Recording Issues - Start Input Stream: No

Recorded calls are loud and clear in both sides.

2 (edited by amlanrd 2019-01-31 19:05:21)

These settings are not working in my Motorola One Power (Android 9.0 - Rooted)
Getting error message: "Recording failed, please change "Alsa Device" in settings and try again."
Please help!

3

Actually suggested settings in the post #1 above work great. You said "failed", two possible reasons:

1. You installed another recorder that blocks Boldbeast working. Please uninstall it.
2. You enabled a Voice Assistant app that blocked Boldbeast working. Please disable it. See [001] in this page http://www.boldbeast.com/android/call_r … oting.html to know how to do it.

Now it should work.

4

Hi,

With above settings boldbeast working great normally. But not working over bluetooth earphone. I enabled "Change Audio Controls" option too. But still its not working.

Shows error : "Recording failed, please change "Alsa Device" in settings and try again."

I usually attend calls over bluetooth only. So boldbeast will be useless for me if it doesn't record over bluetooth.

Please help!

5

With the bluetooth connected, if you use these settings to record calls:

- Record Mode: 1
- Fix Recording Issues - Change Audio Controls: Yes

How about it?