Hi I recently updated my samsung a50 to android 10 and I can no longer record calls.
I have enabled accessibility, I have tried all the sources and the various settings but nothing.
The recordings are all silent. I read that it happens in the samsung a30, a50 and a51. Do you know or do you have any solution?



- In Boldbeast Recorder tap "Call Settings - Manually Record Calls - Hotkey" to open the Accessibility settings screen, enable Boldbeast Call Recorder accessibility service on the screen. 
- In Boldbeast Recorder use Record Mode 12 to record calls.

Now Galaxy A50 Android 10 will record calls great, both your voice and the caller's voice are crystal clear in recordings.

However in some countries the phone still has this problem - recordings are totally silent, or your own voice is good but the caller's voice is very weak in recordings. This is because Samsung disabled the call recording feature in your area. In this case you should root the phone, then Boldbeast Recorder can fix the problem perfectly. If you don't root the phone there will be no solution in the whole world without doubt unfortunately.


1) I have the same problem but if I root the phone I can no longer use my bank's mobile phone app as the app reports the phone as insecure because it has been rooted and the app doesn't install. 

Please find another way to fix the problem without rooting the phone as I can't do without the bank app!

2) I transferred my license/registration from my old phone to the new Samsung A50 and later accepted the A10 update. It then stopped recording calls as above. However the app has now reverted back to a trial status and there are now no fields to re-enter the existing license/register code as I did before the A10 update.

I tried using the 'restore license' method and the Google Play option but there is no Google Play order number on the original  record of the Boldbeast 'Register Code purchased!

Please advise how I can take the phone off trial mode and use the original registration.

Thank you


Transfer license:
https://www.boldbeast.com/forum/topic12 … nsfer.html


I have samsung galaxy a51, android 10. My voice is clear but the caller's voice is faint. I have found out that if I switch the speaker on before starting recording, both voices becomes clear in the recording. I suggest Boldbeast add voice source/ voice communication in the call settings as it is in the memo settings. I could be a go walk around the problem


If needed, you can enable the option "Call Settings - Fix Recording Issues - Auto Switch Speaker On" in Boldbeast Recorder.


Hi. Watch here https://www.boldbeast.com/forum/topic17 … order.html


If I use the earphone, everything is OK.