1

Since I've android 11 (oxygenOS 11) on my Oneplus 8 pro  boldbeast doesn't start anymore. I get a black screen after given permissions to the app.
What to do?

2

We have just released the new version of Boldbeast Recorder V13.8. Please update the app on your phone to V13.8.
We need time to publish the new version in Google Play. At this moment please download it from our web site: https://www.boldbeast.com/android/call_recorder.html
Thanks.

3 (edited by henk.jan.bezemer 2020-10-15 10:06:09)

Thanks for the quick update. The app can be openend like it did. The problem I get is, I can't record now.
I set the clip saving to SAF and created a folder, I also set it to Sandbox: neither works.
I installed the magisk module as supposed in fix recording issues: no effect
Set everything to default settings: no effect
What else to do? It worked always out of the box but now: no old recordings anymore in the list and no new recordings to make.

You help is appreciated again.

With kind regards, Henk-Jan

Update: there are problems for the app to get su privelege. I use magisk canary, grant it but get the error [-3] re-rooting in the app
It seems Boldbeast doesn't recognize the root

4

If there is no coming updated Magisk version (or Boldbeast recorder) so what about making Boldbeast Recorder as Magisk module? Would that help for su privilege problem? Or any latest news about this problem (there´s no solution yet in Magisk Github)?

5

The new Magisk version changed its selinux policies, and that made the "Boldbeast can't get root access" problem.
More info: https://www.boldbeast.com/forum/topic20 … -2-xl.html

6

Yes i know, but You must update your program (and Github issue is now closed). Because there is working apps which require root permissions. Maybe it is not easy but please give us some information. Any plans to try Magisk module or update app and when? And are You sure that closed source code is best way to keep app updated and working?

7

Please see [163] in this page http://www.boldbeast.com/android/call_r … oting.html to know how to fix it.

8

Thanks for reply. I installed Magisk module, and 13.9 version but still no root options. Restarted phone multiple times, granted new root permissions to Boldbeast, installed module again (it is shown on Magisk list)... But it works when i disabled rooted options (except i cant use sandbox for recording location and callers voice is not sot good). And if i try to enable rooted options again, there´s notification that my phone is not rooted.

Pixel 3, Magisk 21.0, Manager 8.0.2.

9

As said in the link above, you should install the special version of the CallRecordingFix module: https://www.boldbeast.com/android/softw … policy.zip

Please do it. It surely works.

10

Like i wrote, i installed Magisk module. But i tried it again, removed, booted, installed Magisk Module (CallRecordingFix), booted, no go.

See the pictures:
https://ibb.co/XsCqd9C
https://ibb.co/C2XDss7
https://ibb.co/6N2T9PX
https://ibb.co/Wf1xG7h
https://ibb.co/tJvc8Zw

11 (edited by henk.jan.bezemer Yesterday 15:40:16)

I got the same problems like Kayttaja99 posted: neither the first nor the second magisk module works. I sent a log but got the same answer as before (this site) which doesn't give a properly solution. I tried to figure out going back to Magisk 20.0 but it can't without a complete wipe which I don't want to.
So a solution that works is highly appreciated.
PM Oneplus 8 pro, OOS 11.N11BA
Model IN2023