1

The call recording feature of Nexus 5X is disabled by LGE, you should root your phone, then Boldbeast Recorder can fix the problem.


Please use these settings to record calls:
- Record Mode: Alsa
- Record Format: MP3
- Alsa Device: Auto
- Alsa Bits: 20 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto
- Tune Audio Effect: Yes
- Tune Audio Route: Group3
- Change Audio Controls: Yes
- Change Audio Driver: No
- Start Input Stream: Yes

Or use these settings to record calls:
- Record Mode: 1
- Record Format: Any
- Tune Audio Effect: No
- Tune Audio Route: Group3
- Change Audio Controls: Yes
- Change Audio Driver: No
- Start Input Stream: test Yes and no


Root
======================
No matter SuperSU or Magisk, no matter Systemless Root or not, Boldbeast works very well with all of them.


Updated 1
======================
If bluetooth recording doesn't work well please change following options to fix it:
- Call Settings - Incoming Calls - Auto Detect Answered State: No
- Call Settings - Incoming Calls - Auto Detect Max Time (Seconds): 3
- Call Settings - Incoming Calls - Restart Recording Upon Answered: No
- Call Settings - Outgoing Calls - Auto Detect Answered State: No
- Call Settings - Outgoing Calls - Auto Detect Max Time (Seconds): 3
- Call Settings - Outgoing Calls - Restart Recording Upon Answered: No


Updated 2
======================
If some calls recorded are crystal clear, however some calls recorded sounds like "the caller's voice is too high, it's a little distorted or garbled", please see the post #57 to know how to fix it.


Update 3 Android 8.0 Oreo
======================
- Please update Boldbeast Recorder to V10.4.
- Changing the "Alsa Bits" to 20 bits will have a better recording quality on Android 8.0.

2

Google Pixel3: Google Pixel 3 Call Recorder
Google Pixel2: Google Pixel 2 Call Recorder
Google Pixel: Google Pixel Call Recorder
Nexus 6P: Nexus 6P Call Recorder
Nexus 6:  Nexus 6 Call Recorder
Nexus 5X: Nexus 5X Call Recorder
Nexus 5:  Nexus 5 Call Recorder
Nexus 4:  Nexus 4 Call Recorder

3 (edited by yurkennis 2016-01-19 15:28:16)

These settings with "Start Input Stream: On" result in very "metallic" distorted voice, both on my and other side. Are there any settings that result in better sound quality of call recording?

I'm running on official build MMB29P (Android 6.0.1), phone model: LG-H790 (32GB).

4

If you disable "Start Input Stream", and try to change "Tune Audio Route" to Group1 or Group2, how about it?

5 (edited by texx 2016-01-29 06:25:13)

boldbeast wrote:

If you disable "Start Input Stream", and try to change "Tune Audio Route" to Group1 or Group2, how about it?

Nothing works. Please advise

official build MMB29P (Android 6.0.1), phone model: LG-H790 (32GB). Just like the other guy

Tried everything you said

6

Please click the "Call Settings - Fix Recording Issues - Ask New Parameters" item in Boldbeast Recorder to send hardware log files to me, let me check them.

7

hi admin.

i am same to user: texx situation  , how to solve it ? thx a lot!!

8

Please send logs to me, let me see what's the reason.

9

boldbeast wrote:

Please send logs to me, let me see what's the reason.

Sent. Please help to fix it thanks a lot!!

10

I made a new version that have been sent to you, please test it and see if there is something different.

11

boldbeast wrote:

I made a new version that have been sent to you, please test it and see if there is something different.

news about the solution ?? I've the same problem :( ....    thx

12

No feedback from tommylau611.

13

i am running with Cyanogenmod and the recorder does not work, what can i do?

14

Cyanogenmod CM13: CM13 Call Recorder

15

boldbeast wrote:

No feedback from tommylau611.

hey sir, i found out another solution without the new version

- Record Mode: Alsa
- Tune Audio Effect: Yes
- Tune Audio Route: Group2 <<!!! important
- Change Audio Controls: Yes
- Change Audio Driver: No
- Start Input Stream: Yes

Last but not least!!!!!
the phone setting > display language must use English(US)

hope it is helpful! :)

16

Changing "Tune Audio Route" doesn't help.
"Display language" is not related to the problem.

17

A user said,

- when he called a friend, the recording was perfect in two directions.
- when he called the customer service number of the operator, in the recording the sound of the other end is distorted.

The reason is, the sound from his friend was normal, the sound from the automatic answer-machine of the customer service was too loud. So please note these situations when you are testing.

18

Another method is turn off the data(internet) , only use 2G network.... it is because 5x not support volte..
I hope admin can modify this problem first.....THX

19

Turning on/off data has nothing to do with the problem.

20 (edited by robis 2016-03-16 07:09:21)

Hi

I would like to ask regarding how to use this software on nexus 5x


Should i only install Call Recorder software  + set those property or should i need also install ALSAMIXER? 

if ALSAMIXER than it is somewhere any tutorial how to set up this software for nexus 5x and Call Recorder?

I tried first and second setting on my H791 - rooted 6.0.1 MHC19J - but without success

thank you

21

Only need to install Boldbeast Recorder, then use suggested settings to record calls. No other apps needed.

Boldbeast Recorder is far more powerful than any other recorders in the market, it has many options to fix recording problems.

There are more than 10000 Android phone models in the market, we know what settings can fix recording problems in some phones, but don't know for other phones. You can test different settings in the app and find the solution for your phone. Users using the same phone will be happy if you share your solution here.

If needed you can click the "Call Settings - Fix Recording Issues - Ask New Parameters" item in Boldbeast Recorder to send hardware log files to us, let us help finding the solution, for any phone model.

22

Hmm... I've just confirmed that my phone is rooted, but I can't select Alsa mode. It's greyed out.

Any ideas?

23

Please click the "Enable Rooted Options" in Boldbeast Recorder, then you'll see the Alsa Mode is available.

24

boldbeast wrote:

Please click the "Enable Rooted Options" in Boldbeast Recorder, then you'll see the Alsa Mode is available.

Aaahh, how did I miss that! Thank you. :)

25

Tried many times and found a working constellation
(sound is a little bit distorted)

Tune Audio Effect: NO
Tune Audio Route: Group1
Change Audio Controls: Yes
Change Audio Driver: NO
Alsa Device: Auto
Alsa Channel: 2 Channels
Alsa Sampling Rate: Auto