26

sadhu wrote:

Hello,
please advice how to set up Boldbeast to record calls on Huawei Mate 10. I searched this forum, tried the recommended setting for Huawei Mate 9, but this does not work for me.
Kind regards
Martin

Same here!

27

Please open the "Settings > Apps > HiVoice" screen, confirm the package name is "com.huawei.vassistant", click "Force Stop", then it works at once.

28

been reading and doing whats been told in this thread..
Settings > Apps > HiVoice - dont work

I wonder
The Huawei Mate 10 pro is loading in the background, not showing those apps, to make it faster for the user..
Could this be a part of this problem ?
After changes recommended in this thread I always try a restart.. check the settings and the recorder..
Dont work..

Annoying as I paid pretty much for the full version

29

Huawei Mate 10 Pro has bugs in the ROM. Please upgrade your ROM to 8.0.0.128, in the new ROM huawei has fixed the bug, call recording works very well now.

30 (edited by wolden 2018-01-14 12:04:12)

boldbeast wrote:

Please upgrade your ROM to 8.0.0.128

There are three different Mate 10 devices. Mate 10, Mate 10 Pro, Mate 10 Lite. For my Mate 10 ALP-L09 Region 432, latest firmware is .125 ATM. I'll wait for 01/2018 update. Right now, I get the "other recorder installed" message, although Google Assistant and HiVoice is set to off. The app itself can't be disabled.

31

Same here. NO GO
Permission showing only Boldbeast have access to microphone
FW ver 128 Mate 10 Pro
THANKS

32

Removed BoldBeast setting unchanged. Install All call recorder lite. Record perfectly without any problem. Settings unchanged.. Fw ver of phone 128

Just for your information

sumedhachin wrote:

Same here. NO GO
Permission showing only Boldbeast have access to microphone
FW ver 128 Mate 10 Pro
THANKS

33

Finally we found the reason is:
Android 8.0 changed something inside, we'll change the app accordingly to fix the problem soon.

34

Thanks for the quick response...

boldbeast wrote:

Android 8.0 changed something inside, we'll change the app accordingly to fix the problem soon.

35

Is there any update yet to this problem ? I have paid for the Pro version and cannot use the app which is rather annoying since it worked fine in every other phone I have owned.

36

We have just released the new version of Boldbeast Recorder V10.8. Please
- update the app in your phone to V10.8.
- click "Set Default Settings" in Boldbeast Recorder.
Then it works.

Google Play may need time to publish it, if at this moment the new version is not available in your area please download it from our web site: https://www.boldbeast.com/android/call_recorder.html

37

Working now perfect on my Huawei Mate 10 Pro after the latest update. It took a while to get it done but thanks to the Team of Boldbeast for their continious efforts. You have a great and exceptional product, take good care of it.

38

Lutziefer wrote:

Working now perfect on my Huawei Mate 10 Pro after the latest update. It took a while to get it done but thanks to the Team of Boldbeast for their continious efforts. You have a great and exceptional product, take good care of it.

Sure, we will. Thanks.

39

Thank you for your upgrade it is working Fine . Cheers...

40

I'm having some recording issue with my Mate 10 Pro. I tried every recommended recording settings, but incoming calls are only recorded if I turning on "Tune Audio Effect" option, and incoming calls are recorded only, if the screen is not locked. When I get an incoming call and screen is locked, the recording indicator isn't there, and incoming call does not recorded at all. Does anyone have the same issue?

My settings and versions:

Huawei Mate 10 Pro Build: 8.0.0.131
Boldbeast version: 10.9 GP PRO
Auto Record Call = All
Record Mode = Mode1
Tune Audio Effect = On
Tune Audio Route = Group3
Ask Before Save = On

Every other settings are default.

Thanks!

41

eszzsolt wrote:

When I get an incoming call and screen is locked, the recording indicator isn't there, and incoming call does not recorded at all. Does anyone have the same issue?

Please fix it this way, see [002] in this page http://www.boldbeast.com/android/call_r … oting.html

42

"App Settings > Standby Indicator" was already switched on.
There's no "Settings > Phone Manager > Protected Apps" screen, and "Settings > Power Saving > Protected Apps" screen is also not available on this phone, but I put Boldbeast to "Settings > Apps > Advanced > Ignore Optimizations" list.

Unfortunately, the result is the same. Incoming calls are not recorded if screen is locked.
Any other idea?
Thanks!

43 (edited by eszzsolt 2018-03-28 08:29:06)

Ok, I found the solution. There's "Settings > Battery > Optimization" screen, and on that screen I have to turn off Automatic mode on Boldbeast, and I have to set starting and background running parameters manually. Now I see "Boldbeast Recorder - On standby" on the lock screen, and incoming call is recorded successfully.
Thanks for the help!
Cheers

44

For me the reason for buying your software was to get full quality on the speech from the other side, something all other apps I tried so far failed with. Yours worked until 24/12 then something happened and now it is as bad as the others (weak nearend and super weak farend). Possibly there was a firmware update from Huawei that got installed at the time. I have tried remove and reinstall B without success. I think I used mode 1, now I tried 1, 5 and both seems to rec from mic instead of in software directly. What now? EMUI: 9.0.0.161, B: 11.8GP pro version.

45

You should root the phone to fix the problem.

46

I have the Mate 10 Pro. It did not need to be rooted but worked non-rooted as mentioned above (as for many others, in difference from non Profit version). Do you mean that you can't fix this in your next release and I instead need to root my phone? In such case I demand my money back! I can not root my phone for legal reasons. I hope it is fixable!

47

Gungan wrote:

Do you mean that you can't fix this in your next release and I instead need to root my phone?

Yes, you are right. This is exactly what I mean.
There is no solution in the whole world without root. However with root this app is the solution.

48

boldbeast wrote:
Gungan wrote:

Do you mean that you can't fix this in your next release and I instead need to root my phone?

Yes, you are right. This is exactly what I mean.
There is no solution in the whole world without root. However with root this app is the solution.

If i root, can you please advise how to set so that both sides can be recorded clearly?

49

If you have root the phone, please use the settings to record calls:

- Record Mode: Alsa
- Alsa Device: Auto
- Alsa Bits: 16 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto

How abut it?