1 (edited by sadhu 2017-11-20 11:54:07)

Hello,
please advice how to set up Boldbeast to record calls on Huawei Mate 10. I searched this forum, tried the recommended setting for Huawei Mate 9, but this does not work for me.
Kind regards
Martin

2

Huawei Mate 10, please use these settings to record calls:

- Record Mode: 1 or 5
- Record Format: MP3
- Tune Audio Effect: No
- Tune Audio Route: Group3

It records calls very well in two sides.



Update 2018-02-07
==============
1. Old versions of Boldbeast Recorder don't work well.
2. Boldbeast Recorder V10.8 and newer versions work great.



Huawei Mate 20: Huawei Mate 20 Call Recorder
Huawei Mate 10: Huawei Mate 10 Call Recorder
Huawei Mate 9: Huawei Mate 9 Call Recorder
Huawei Mate 8: Huawei Mate 8 Call Recorder
Huawei P20: Huawei P20 Call Recorder
Huawei P10: Huawei P10 Call Recorder
Huawei P9: Huawei P9 Call Recorder
Huawei P8: Huawei P8 Call Recorder
Huawei Honor 10 View: Huawei Honor 10 View Call Recorder
Huawei Honor 9: Huawei Honor 9 Call Recorder
Huawei Honor 8: Huawei Honor 8 Call Recorder
Huawei Honor 7: Huawei Honor 7 Call Recorder
Huawei Honor 6: Huawei Honor 6 Call Recorder
Huawei Note 8: Huawei Note 8 Call Recorder
Huawei G8/G7: Huawei G8 / G7 Call Recorder
Huawei Nova: Huawei Nova Call Recorder

3

Thank you for the advice,but this unfortunately did not work for me.

4

We have just released the new version of Boldbeast Recorder V10.4, several recording parameters have been changed in it. Please update the app in your phone to V10.4 and test again. How about it?


UPDATE 2018-02-07
---------------------------
V10.4 don't work, please update the app to V10.8, it works great now.

5

Tried the new version with your recommended settings, still does not work.

6

Please check if your phone has the problem described in the [004] part in this page http://www.boldbeast.com/android/call_r … oting.html

7

Same problem here. Don't work.

8

wwka01 wrote:

Same problem here. Don't work.

See the [004] part for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html

9

Hi,

I get constant error message only one recording app is possible at each time and I have to deactivate the other recording app. But I didn't installed any. I removed all access to microfone except phone and Boldbeast. Still not working. Please advise.
I followed [001] All calls are not recorded, why? But it didn't solve the problem.

Kind regards

Lutziefer

10

Please disable the Huawei Voice Assistant, some phones name it HiVoice.
In some Huawei phones, in the Dialler app you should disable the "Quick Calling" option.
In some Huawei phones, you should disable the "Contacts > Settings > Fast Calling" option.
In some Huawei phones, you should disable the"Settings > Smart Assistance > Voice Control" option.

11

Tried everything, no luck.  Just tried "Factory default", and only Boldbeast, same shit about "Another call recorder".

My language are Norwegian, also in settings, but I've found every advice.
Even found "Standard keyboard = SwiftKey".  Pressed it, and got a "Config ....", where "Google speak .." was on.

But it don't work nomather what.  The recording icon turns on for a short while, and off.  Manually staret, turns off after 2-3 sec.

Please excuce my spelling

12

Yes correct,I never installed another recorder on the mate 10 pro,i shut off google speak and i gave only boldbeast,camera and the phone the permission for the micro......no way.
I am using software 10.5 gp pro version in German.
The record button starts for 2 seconds and shut off same as on Luziefer´s phone

Please come up with a better solution

Thank you

Regards

Chris

13

Please:
- Uninstall Boldbeast Recorder.
- Install another recorder (any recorder in the market).
Now test again.

What will happen?
Undoubtedly you'll find all recorders don't work in your phone.

Why?
Because Huawei Voice Assistant is working that blocks the recorder (any recorder).

How to fix it?
See the post #10 above.

14

boldbeast wrote:

Please:

Because Huawei Voice Assistant is working that blocks the recorder (any recorder).

How to fix it?
See the post #10 above.

Done, did not help.

15

did not help
all was shut off,i revised twice...
even if I hit the bottom manual  while a call.....I cannot save the call

16 (edited by Gravingen 2017-12-03 17:58:05)

Post 13, Thank you.  Tried All Call Recorder from Electro Dev

Worked.  No other change, just uninstall & install.

17

Gravingen wrote:

Post 13, Thank you.  Tried All Call Recorder from Electro Dev

Worked.  No other change, just uninstall & install.

If Boldbeast Recorder doesn't work, all other recorders don't work either.
If any other recorder works, Boldbeast Recorder works also for sure.
Test again.

18

I can confirm it
Have removed boldbeast,install all call recorder 2018 lite from electro dev and it works perfectly


boldbeast wrote:
Gravingen wrote:

Post 13, Thank you.  Tried All Call Recorder from Electro Dev

Worked.  No other change, just uninstall & install.

If Boldbeast Recorder doesn't work, all other recorders don't work either.
If any other recorder works, Boldbeast Recorder works also for sure.
Test again.

19

To make your Mate 10 / Mate 10 Pro work, you should
- uninstall all other recorders, only leave Boldbeast Recorder working in your phone.
- disable "OK Google", see [001] in this page http://www.boldbeast.com/android/call_r … oting.html to know how to do it.
- disable "Huawei Voice Assistant", see [001] in the same page.
Then your phone works.

20

mexicostadt wrote:

I can confirm it
Have removed boldbeast,install all call recorder 2018 lite from electro dev and it works perfectly


boldbeast wrote:
Gravingen wrote:

Post 13, Thank you.  Tried All Call Recorder from Electro Dev

Worked.  No other change, just uninstall & install.

If Boldbeast Recorder doesn't work, all other recorders don't work either.
If any other recorder works, Boldbeast Recorder works also for sure.
Test again.

All Call Recorder 2018 Lite still works.  Other side a bit weak.

21

Uninstalled All Call Recorder, and installed Boldbeast, setup as usual.
Following no change:
"OK Google" don't work in Norwegian, disabled (Settings-Google-Search-Setup (top line)-Phone)
"Huawei Voice Assistent" disabled (in the Dialler app the "Quick Calling" option are disabled)

No reaction on Boldbeast, trying manual auto stop in 3 secunds, no recording.
Tried "default settings", same result.

Uninstalled Boldbeast, installed All Call Recorder.  Records in & out, low quality, but works.

When my phone was brand new 8 days ago, Boldbeast did work for a day or two (low recording, week in full volume), but suddenly stopped with the "another recorder" error.  Never heard of "OK Google" or "Huawei Call assist" then.

I didn't have any other, but removed anything with access to the microphone.  No change.
Read here, and found both those problems disabled.
Then restored to factory defaults, and installed Boldbeast.  Checked both, disabled.
Same error, "another recorder".

22

Thank you for the information.

I have just downloaded and checked the recorder you said, it uses the "OpenSL ES" native audio library to record calls. This library allows "shared recording" from Android 8.0 up, this is the reason why it can but other recorders can't record calls while Huawei Voice Assistant is working.

However "shared recording" can NOT fix the "caller's voice is weak" problem.

At this moment as far as I know, the only solution is the post #19 above.
Many Mate 10 users have made it working. If it doesn't work it's because you have not really disabled Huawei Voice Assistant. You must disable it, then it works.

23

I try all steps from #19 but don't work.
Ok Google is off and quick call is off.
No chance to work :-(

Perhaps anything who works the recorder can show us pictures from his settings.

24

I gave up the Huawei Mate 10 Pro, due to other problems as well.  Returned to seller.

25

I have shut off all possible and the boldbeast does not work...

WHY?