1

Got one of the OnePlus 6 phone today, and tried the setting recomended for the 5T but boldbeast will not record. Any ideas what setting to use?

2

OnePlus 6 works very well, recorded calls are loud and clear in both sides. No root needed.

Please
- update Boldbeast Recorder to the latest version (currently V11.5).
- click "Set Default Settings" in the app, it works at once.

If the problem is still there, please enable the "Call Settings - Fix Recording Issues - Tune Audio Effect" option, then it 100% works.

3

OnePlus 6: OnePlus 6 Call Recorder
OnePlus 5, 5T: OnePlus 5 Call Recorder
OnePlus 3, 3T: OnePlus 3 Call Recorder
OnePlus 2: OnePlus Two Call Recorder
OnePlus X: OnePlus X Call Recorder
OnePlus One: OnePlus One Call Recorder

4

Thank you, default settings work great.  Good quality recording..

5

I'm trying to get V11.8 to work on my Oneplus 6 running stock android 9....but I can't get it to work. I can only hear myself.

I started running the default settings and then tried all the different recording modes without luck. Any suggestions?


Best regards,
Lodberg

6

Lodberg wrote:

I'm trying to get V11.8 to work on my Oneplus 6 running stock android 9....but I can't get it to work. I can only hear myself.

So all recorders in the market no longer work in OnePlus 6 Android 9.

You should root the phone, then Boldbeast Recorder can fix it perfectly. After root the phone please enable the "Call Settings - Fix Recording Issues - Change Audio Controls" option in the recorder, you'll get crystal clear recordings in both sides. The option is visible only after you root the phone.

Without root there is no solution in the whole world undoubtedly.

7

Thanks

8 (edited by xtruss 2018-10-07 07:45:44)

Lodberg wrote:

I'm trying to get V11.8 to work on my Oneplus 6 running stock android 9....but I can't get it to work. I can only hear myself.

I started running the default settings and then tried all the different recording modes without luck. Any suggestions?

I had the same issue once my phone updates to Android 9, i didn't want to root though as it is to much bother with ota's and one of my banking apps.
There is a way to enable the inbuilt call recording on the oneplus6 running android 9 with no root, i have done it on my phone and a friends and it works fine.
Have a look on the play store for an app called joneplustools
Once enabled, go to the phone dialler and in settings you will see the switches to turn on call recording.
To access recorded calls, go to the phones "recorder" app, and swipe the screen across to audio recording files.
Hope that helps.

9 (edited by ditndat 2018-11-07 13:16:52)

I installed the app (oneplus 6 with android 9), can record both ways and enabled the enable the "Call Settings - Fix Recording Issues - Change Audio Controls". Though when i want to play back a recording, it only plays in slow motion. Any ideas how to fix this?

10

ditndat wrote:

when i want to play back a recording, it only plays in slow motion

Obviously there is a bug in the AudioServer inside the ROM - the AudioServer wrongly deals with audio resampling that made the problem. Boldbeast can fix the problem by changing the sampling rate in the app.

After root your Android 9.0 phone, please use these settings to record calls:

- Record Mode: 1
- File Sampling Rate: test 16000, 32000, 44100, 48000 one by one
- Fix Recording Issues - Change Audio Controls: Yes
- Fix Recording Issues - Change Audio Driver: No
- Fix Recording Issues - Start Input Stream: No

One of the options 16000, 32000, 44100, 48000 will produce crystal clear recordings, please test and find out that option and use it.


Or use these settings directly to record calls:

- Record Mode: Alsa
- Alsa Device: Auto
- Alsa Bits: 16 Bits
- Alsa Channels: Auto
- Alsa Sampling Rate: Auto
- Fix Recording Issues - Change Audio Controls: Yes
- Fix Recording Issues - Change Audio Driver: No
- Fix Recording Issues - Start Input Stream: No

The Alsa engine is made by us, it doesn't rely on the AudioServer so it can bypass the bug in the ROM.

11

It was idd rooted though the mentioned settings didn't fix the problem. The fix was to set the record mode to Alsa mode (root).

12

ditndat wrote:

It was idd rooted though the mentioned settings didn't fix the problem. The fix was to set the record mode to Alsa mode (root).

Thank you for testing and confirming the Alsa settings work well.

13

Using ALSA worked perfectly for me on AOSP 9.0 Rom. Clear at 48000hz sample rate