126 (edited by vtmr017 2021-03-24 09:24:25)

I'm getting Cannot record calls.
Android allows only one recorder working,So you must remove or force stop All recorders in your phone...

But I don't have any other recorders other than in built native android Screen recorder.
I'm using Android 11 pixel experience custom rom on my Asus zenfone max pro m1.
Any solution...?

127

Please see [009] in this page http://www.boldbeast.com/android/call_r … oting.html to use suggested settings to record calls.

128

Why is it asking me for a password?

129

By default the app needs no password. It asks you for the password because you previously set a password.

If you forgot the password, please see here:
https://www.boldbeast.com/forum/topic1702-password.html

130

first time visitor... I have a BLU G90 Pro phone with Andriod 10.  I've installed Boldbeast, it defaulted to mode Mode 12 and I can hear my side of the conversation clearly... but the other side is silent.  I've tried a couple of other modes, but I haven't gotten to hear the other side.  Are there any other settings I should look at?  What are the downsides of rooting the phone, and does that guarantee Boldbeast will work?

131

If your voice is good but the voice of your friend is weak or silent in recordings, you should
- Switch on the loudspeaker during a call, so Boldbeast can record the call on both sides normally. Or
- Root the phone, so Boldbeast can fix it completely to record calls on both sides perfectly without switching on the loudspeaker.

About root please have a look at this link:
https://rootmydevice.com/how-to-root-android-device

If you root the phone, on Boldbeast Recorder please set "Record Mode" to Alsa2 Mode, then it works at once.
The Alsa2 Mode works great. So far there is no user who said it doesn't work. I believe it works well on all phones running Android 10 and newer versions.

132

Hello
I don't want to record my calls. I did everything according to the instructions ""After root the phone"": https://www.boldbeast.com/forum/post7898.html#p7898
Shows a message:
>>> Cannot record calls. Android allows only one recorder working, so you MUST remove or force stop ALL other recorders in your phone, otherwise this app will surely fail to record calls because of conflicts.<<<
I turned off the google assistant, system recorder and nothing. What I doing wrong?
My phone:
Samsung galaxy s7 edge
rom: Lineageos 17.1  - android 10
root: Magisk

133

hasto wrote:

Shows a message:

First please uninstall all other recorders, then use Alsa2 Mode in Boldbeast to record calls. Now it should work.
If the problem is still there, please tap "Call Settings - Fix Recording Issues - Ask New Parameters" to send log files to me, let me have a look at them and see what happened in your phone.

134

I sent it to service@boldbeast.com

135

hasto wrote:

I sent it to service@boldbeast.com

I have not received your log files.
If you used another email box sending the files, please send a new email to tell me. Otherwise I can't know which email is yours. I have many emails every day.

136

boldbeast wrote:
hasto wrote:

I sent it to service@boldbeast.com

I have not received your log files.
If you used another email box sending the files, please send a new email to tell me. Otherwise I can't know which email is yours. I have many emails every day.

I sent again. The subject of the message is HASTO

137

still not working. I did everything with [009]. I keep getting the message: “Unable to record calls. Android only allows one recorder to work, so you MUST delete ALL or force stop them ... " The system recorder is turned off, OK, google too. What else can block apps? Whatsapp ?, Messenger?

138

If you set "Record Mode" to Mode1, can it save the call?

139 (edited by drpo 2021-04-24 15:59:20)

Hello!
I am using a Xiaomi Mi 11 phone, rooted, on Android 11 (MIUI 12)
I have read the entire FAQ and my problem most likely relates to: [002] Some calls are recorded but some calls are not, it seems randomly, why?

If the calls have been recorded, they are perfect.
When I call, everything is recorded as it should ... at least for now.
When I answer a call it can be different.

As mentioned in the FAQ, I have disabled Boldbeast battery optimization. I have turned off Ok Google. I checked all other apps' microphone access ... and noticed one thing:

Google has access to the microphone at all times. Boldbeast only has access while in use, and I can't change that so that it has continuous access (that's probably an implemented feature in Android 11, if I remember correctly).
And now the question is, can this cause incoming calls to not be recorded correctly? Does Boldbeast activate microphone access when receiving a call?
And is there any solution for this?

Thank you for your response.
(I send you my log)

P.S. Maybe we will pin the topic: Android 11 Call Recording? :)

140

boldbeast wrote:

If you set "Record Mode" to Mode1, can it save the call?

No, it automatically goes back to alsa2. what apps should i turn off? or take away microphone permissions?

141

hasto wrote:
boldbeast wrote:

If you set "Record Mode" to Mode1, can it save the call?

No, it automatically goes back to alsa2. what apps should i turn off? or take away microphone permissions?

So another app is using the microphone and that blocked Boldbeast working.
Please revoke the Microphone permission from all other apps, then it will work at once.

142

drpo wrote:

I am using a Xiaomi Mi 11 phone, rooted, on Android 11 (MIUI 12)
If the calls have been recorded, they are perfect.
When I call, everything is recorded as it should ... at least for now.
When I answer a call it can be different.

Your phone killed Boldbeast Recorder, and this made your incoming calls not recorded.
On some phones you should "lock" the app to prevent it being killed. I guess your phone has something similar. Please find the related setting and change it to avoid the app being killed again.

143

Having problem that crept up out of nowhere. Was using the VOIP recorder with root to record calls taken on google voice. no problems. Yesterday, however, call I recorded played back all sped up and garbled. No idea why.

Same thing with call recorded today.

Sent an email last night and today with the log files for both, can upload the garbled call somewhere if you'd like if it would help.

I'm on Xiaomi Redmi Note 9S Android 10.

(actually I sent you today's 5 min garbled call to service@boldbeast.com with subject line "Recordings with voip recorder are recorded at 1.2x or something?"

144

edward wrote:

Was using the VOIP recorder with root to record calls taken on google voice. no problems. Yesterday, however ... Recordings with voip recorder are recorded at 1.2x or something?

I checked your log files.
The file "/vendor/lib/hw/audio.primary.atoll.so" in your phone has something different inside, and this makes the problem. I have just made a new version of the CallRecordingFix module, please use Magisk Manager to install it, then the problem will be fixed at once.

145

Good morning, I have a Samsung Galaxy A8 (2018) SM-A530F. I have installed a custom ROM (FusionX, with Android 10) and everything works fine except boldbeast - I can't get it to work anymore. In particular, I receive the message "Android allows only one recorder working,So you must remove or force stop All recorders in your phone..."

My phone is rooted, and I have tried all the different combinations suggested in the first post. I have also deactivated Google Voice Match, and only allowed boldbeast to have permission ot use the mic. I have tried uninstalling and reinstalling boldbeast and the Magisk module. But no luck.

Any suggestion would be very welcome! (apart from the obvious "return to official Android 9"?

Thank you very much.

146

great. I also have call recorder on my android and ios phone

147 (edited by phisada 2021-10-15 18:47:13)

Rooted Pixel 2 on Android 10.  Up until several months ago bb worked flawlessly. Then it started recording some calls but not others. Tried many suggested settings, now will not record, only silence. Tried uninstall reinstall but bb will not request root access. How can I force it to do that?
Thanks

Update. Finally got root access but still having inconsistent results. One call will record but one minute later next call will not. Please advise. I've been emailing support for days now and no response.

Edit:  Found the solution.  If your recordings are sometimes blank despite trying everything support recommends, then turn off Wifi Calling.  For Android 10, when in the phone app, click the three dots in the upper right, go to settings, calls, Wifi calling, then slide the slider to the left to turn it off.  That was it.  I think in my case some calls would use wifi calling and others not.  Any wifi calls would have blank recordings.  That's why the issue was intermittent.  BB, you owe me a reward for solving this!

148

I bought the pro version of Boldbeast Call Recorder a long time ago and everything was working fine, but since updating my Xiaomi Redmi note 8T Europe version to Android 11 the app only records my caller but not my voice. the device is rooted and the module was installed with MAGISK MANAGER so I tried everything in configuration, I put on ALSA 2 and I have my voice but not that of my interlocutor. Could you educate me on that so that I can have both audible voices on either side. However before on android 10 I had no problem but since android 11 ....... You can help me thank you
Otherwise

149

Hi. I use Umidigi A9 Pro, Android 10. I try all settings, but still I hear only my voice. I send you hardware logs, maybe you can do something with it