1 (edited by PepeCZ 2017-06-25 13:20:37)

Hi, into this time on my old phone OnePlus 3 I using Boldbeast recorder .. without problems.
(only sometimes, red button stick on display, but this always fix, when I fast call some telephone number, and immediately calling close)

But what about OnePlus 5?

I bought this phone two days back, but I cannot find settings for this phone on your website. Can someone give help? Thanks

2

Please use these settings to record calls:

- Record Mode: 1 or 4 (thanks to leekyuh, he said 14 works better)
- Tune Audio Effect: No
- Tune Audio Route: Group3

No root needed, OnePlus 5 A5000 records calls crystal clear in two sides.

3

OnePlus 6: OnePlus 6 Call Recorder
OnePlus 5, 5T: OnePlus 5 Call Recorder
OnePlus 3, 3T: OnePlus 3 Call Recorder
OnePlus 2: OnePlus Two Call Recorder
OnePlus X: OnePlus X Call Recorder
OnePlus One: OnePlus One Call Recorder

4

Thanks so much for these settings for the OnePlus 5. They work OK but my voice is much quieter than the other person's. Would you have any advice for a tweak so that the volumes are equalized?

Thanks again!

5

boldbeaster wrote:

They work OK but my voice is much quieter than the other person's.

Are you recording via a bluetooth device? If so please see the [006] part for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html

6

boldbeast wrote:

Are you recording via a bluetooth device? If so please see the [006] part for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html

Thank you, the levels are more even now. Great work! :-)

7

The record button turns off after 5 seconds and no recording is made.

I have tried the recommended settings and turned off google voice.   
- Record Mode: 1 or 4
- Tune Audio Effect: No
- Tune Audio Route: Group3

8

dweissnj wrote:

The record button turns off after 5 seconds and no recording is made.

Three possible reasons:

1. You are using a wrong location to save recorded calls. Please check the "App Settings - Clip Saving Folder" option in Boldbeast Recorder.

2. There is another recorder working in your phone that blocks Boldbeast. Android allows only one recorder working, so you MUST remove ALL other recorders at first, otherwise Boldbeast will surely fail to record calls.

3. You enabled the OK Google app in your phone. OK Google is occupying the microphone, it is continuously picking up sound from the microphone to recognize your "voice command", and this blocks Boldbeast working. Please disable the following option in your phone:
  - In some phones, disable the "Settings > Google > Search > Voice > OK Google detection > From any screen" option.
  - In some phones, disable the "Settings > Google > Search > Voice > OK Google detection > Say Ok Google any time" option.

No other reasons, only these three possible reasons, please check them one by one.

9

Using stock OS 4.5.6, Boldbeast doesn't autorun.  No, not even its service.  Was using it on Nexus 5X until yesterday, it did autorun.

10

PornFlakes wrote:

Using stock OS 4.5.6, Boldbeast doesn't autorun

Please see the [001] and [002] parts for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html

11

It turns out battery optimization in OOS kills some apps' autorun (e.g. Tasker and this app). Lineage OS battery optimization doesn't do that. Thanks, I fixed it.

12

I just replaced my Galaxy S5 with OnePlus 5. Boldbeast installed itself fine on the OnePlus, but it won't record anything. I suspect the reason is that on the S5 I chose "Primary SD Card" as the Clip Saving Drive setting.

Now Boldbeast insists on creating a recording file called /sdcard/com.boldbeast.recorder/rec and, of course, the OP5 does not have an SC Card slot.

Moreover, the copy that was installed on the OP5 does not have a Clip Saving Drive option, so I can't change that.

Please advise.

13

dear Boldbeast,

I am having one-plus 5. Now i have put my phone on deep clean option in the settings which closes all the apps running in the background. if i open the app and then make any calls it works perfectly fine but the issue come when i press close all apps.

When ever i close all the apps the bold beast app also closes. Now if i make any calls their is no auto call recording which i have get only when i open the app again.

is there any way i can make this app such that it is not closed in the deep clean mode. can their be some permissions or anything.

Deep clean helps me in managing the battery a lot. but i dont want bold beast also to close. pls help

thanks
gaurav

14 (edited by leekyuh 2017-09-28 12:43:18)

I also had an issue of app not recording anything on my OP5 128 GB. I followed BoldBeast's suggestions but none of them worked.
I fixed it by setting to Recording Mode 14. I have no idea what these modes are, but only mode 14 was working. Sound is very clear, satisfied!

15

ilkka.rantaaho@gmail.com wrote:

I just replaced my Galaxy S5 with OnePlus 5. Boldbeast installed itself fine on the OnePlus, but it won't record anything. I suspect the reason is that on the S5 I chose "Primary SD Card" as the Clip Saving Drive setting.

Now Boldbeast insists on creating a recording file called /sdcard/com.boldbeast.recorder/rec and, of course, the OP5 does not have an SC Card slot.

Moreover, the copy that was installed on the OP5 does not have a Clip Saving Drive option, so I can't change that.

Please advise.

All android  phones have a primary sd card (internal sd card). Some phones have a removable sd card (external sd card). If your phone has a removable sd card Boldbeast will display the "Clip Saving Drive" option to let you choose which card to be used to save recordings. If your phone has no removable sd card you can only save recordings in the primary sd card, you have no other choice, so the "Clip Saving Drive" option is invisible - everything is well.

You said your OnePlus 5 "not record anything", please
- update Boldbeast Recorder in your phone to V9.9.
- some phones need to power off and power on after installation, then it works at once.
- if the problem is still there, see the [001] part for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html

16

gauravaggarwal1 wrote:

dear Boldbeast,

I am having one-plus 5. Now i have put my phone on deep clean option in the settings which closes all the apps running in the background. if i open the app and then make any calls it works perfectly fine but the issue come when i press close all apps.

When ever i close all the apps the bold beast app also closes. Now if i make any calls their is no auto call recording which i have get only when i open the app again.

is there any way i can make this app such that it is not closed in the deep clean mode. can their be some permissions or anything.

Deep clean helps me in managing the battery a lot. but i dont want bold beast also to close. pls help

thanks
gaurav

Some phones have a built-in app named System Cleaner,  Deep Clean or something similar, when it does the cleaning task it kills apps by its policy. If Boldbeast is killed your calls will not be recorded. In this case please add Boldbeast into its "White List", so that it will no longer kill Boldbeast.

17

leekyuh wrote:

I also had an issue of app not recording anything on my OP5 128 GB. I followed BoldBeast's suggestions but none of them worked.
I fixed it by setting to Recording Mode 14. I have no idea what these modes are, but only mode 14 was working. Sound is very clear, satisfied!

Actually Record Mode 1 works very well.
Thank you very much for sharing this "Recode Mode 14" information, it's surely useful for other OnePlus 5 users.

18 (edited by sjamie 2017-10-05 06:19:04)

boldbeast wrote:
leekyuh wrote:

I also had an issue of app not recording anything on my OP5 128 GB. I followed BoldBeast's suggestions but none of them worked.
I fixed it by setting to Recording Mode 14. I have no idea what these modes are, but only mode 14 was working. Sound is very clear, satisfied!

Actually Record Mode 1 works very well.
Thank you very much for sharing this "Recode Mode 14" information, it's surely useful for other OnePlus 5 users.

Mode 14 is the only mode that works for me.  Thanks for the info!
I am finding the settings I need for successful recording change based on the ROM I'm using.  Non-OOS based ROMs don't seem to play as well with BoldBeast.  I'm currently using xXx NoLimits ROM (OOS based) and recordings sound very good even over bluetooth.

19

Hi, it is me again, with a different issue. Since I have upgraded to Oreo (OOS 5.0.1, latest official firmware), I cannot prevent the system to kill the call recorder after like 3 or more hours of sleeping. I have disabled all battery optimization settings. This didn't happen with Nougat.

20

Other phones running Android 8.0 Oreo doesn't have the "auto kill apps" problem. I guess there are settings somewhere in your phone you can tune to change the behavior, please check built-in settings.

21 (edited by PornFlakes 2018-01-15 04:36:11)

I have checked all the settings available on this phone many times already. There are some apps that have been updated to "counter" against the new behavior over background apps in Oreo. And those apps don't get killed. Just my 2 cents. For now I am reopening the call recorder whenever it has been terminated (I rarely make or receive calls, probably there are only few on Oreo right now, and those few that are on Oreo make calls frequently, that's why they haven't experienced this issue yet).

Update: even though the app gets killed, the app reopens by itself after I make a call and the call is recorded, and the notification reappears. So all is good for now.

22

I confirmed that the recommended settings are working well with the OnePlus 5T.
I am using OOS OB2 (Oreo Beta2)
I selected Recording Mode: 1 and 14. Both are working well.
If you want to create a OnePlus 5T section, you can recommend those settings.