1

Hi, I used call recorder for Note 7 and it worked perfectly.
Unfortunately Note 7 was recalled, so I just bought a Google Pixel XL.  The call recorder doesn't work at all.  I've tried many settings, still no luck.  I really wish it work out without rooting.
Any suggestions?  Thanks.

2

Can you please click the "Call Settings - Fix Recording Issues - Ask New Parameters" item in Boldbeast Recorder to send hardware log files to me? let us check your log files and other files copied from your ROM, then we can know if root is needed or not.
Thanks.

3

So I've sent log files, hope it helps.  Thank you!

4

I checked files copied from the Android 7.1 ROM in your Google Pixel XL, unfortunately Google deleted several important recording parameters from the ROM, as a result all recorders in the market will surely not work well - you can only record your voice, the caller's voice can't be recorded.

So you need to root the phone, then Boldbeast Recorder can fix the problem.

After root the phone, please use these settings in Boldbeast to record calls:
- Record Mode: 1
- Tune Audio Effect: No
- Tune Audio Route: Group3
- Change Audio Controls: Yes
- Change Audio Driver: No
- Start Input Stream: No
- File Sampling Rate: Auto, if the recording sounds like slow motion please change it to 16000

Or use these settings to record calls:
- Record Mode: Alsa
- Record Format: MP3
- Alsa Device: Auto
- Alsa Bits: 16 Bits
- Alsa Channels: 1 Channel
- Alsa Sampling Rate: Auto (change to 16000 for Android 8.0)
- File Sampling Rate: Auto
- Tune Audio Effect: No
- Tune Audio Route: No
- Change Audio Controls: Yes
- Change Audio Driver: No
- Start Input Stream: No


Root
========
No matter SuperSU or Magisk, no matter Systemless Root or not, Boldbeast works very well with all of them.


Updated 1
========
Some users met this problem: when play back recorded calls it sounds like "slow motion", this is because there is a bug in the audio server inside the ROM that made the problem. In this case please:
- change "File Sampling Rate" to 16000 to fix the problem. Or
- use the Alsa settings above to record calls, it can bypass the bug.


Updated 2
========
Google Pixel Android 8.0 Oreo needs root. After root the phone, please:
- update Boldbeast Recorder to the latest version.
- use the Alsa settings above to record calls, and please change the "Alsa Sampling Rate" to 16000, then it records calls crystal clear in two sides.


Updated 3
========
Google Pixel Android 9 Pie needs root. After root the phone, please:
- update Boldbeast Recorder to the latest version (currently V11.8).
- use the Alsa settings above to record calls, it records calls crystal clear in two sides.


Update 4
=======
From users' reports, actually in some market areas the call recording feature of Pixel / Pixel XL is not disabled by Google, in some areas it is disabled.

If the call recording feature of your phone is not disabled it records calls crystal clear in two sides, just install Boldbeast Recorder and go, no root needed, no settings need to be changed. Please click "Set Default Settings" in the app if needed.

5

Google Pixel3: Google Pixel 3 Call Recorder
Google Pixel2: Google Pixel 2 Call Recorder
Google Pixel: Google Pixel Call Recorder
Nexus 6P: Nexus 6P Call Recorder
Nexus 6:  Nexus 6 Call Recorder
Nexus 5X: Nexus 5X Call Recorder
Nexus 5:  Nexus 5 Call Recorder
Nexus 4:  Nexus 4 Call Recorder

6

Update:

So I've rooted my Pixel XL, and Alsa mode seems working fine so far.  That's enough for me.  If I encounter any more problem I'll post here.

7

DT wrote:

So I've rooted my Pixel XL, and Alsa mode seems working fine so far.  That's enough for me.  If I encounter any more problem I'll post here.

Thanks for sharing the information.

8

DT wrote:

Update:

So I've rooted my Pixel XL, and Alsa mode seems working fine so far.  That's enough for me.  If I encounter any more problem I'll post here.

What is the tool you used for rooting Pixel?

9

honxrv15 wrote:

What is the tool you used for rooting Pixel?

Well, it's not a rooting forum and it's a very complicated topic.  Anyway just search unified Android toolkit.

10 (edited by 00jirka 2017-01-19 09:43:12)

Hi there,

I rooted my Pixel, set all as written here, using Alsa and everything works fine even in my car when I perform a hands free - bluetooth call. I bought the PRO version to have an automatic recording possibility. I set it to ask if save or not after each call, but once I press yes/no the whole application starts and I jumps to settings. Then I have to exit it, what I see useless. Is it possible to just choose yes or no and be on the same place as I was before the call?

Thanks.

11

Please open Boldbeast Recorder,

- if you click the Back key to quit the app, then it will work just as you want.
- if you click the Home key to leave the app instead of quit it, then it will work as you described above.

This is the standard behaviour of Android, not of Boldbeast Recorder.

12 (edited by Badhabit_wb 2017-01-20 00:38:48)

I rooted my pixel and used the setting suggested and it works fine on cellular calls. When I get a wifi call the caller can't hear my voice. Something in the boldbeast app is blocking it. If I use titanium to freeze boldbeast the call works fine. Any ideas about what setting I can use to change this? The pixel uses wifi calling a lot and I need to be able to answer incoming wifi calls even if they're not recorded. I have phone set to automatically record calls. If I turn this off I can also answer calls.

I'm on the official rom. Start Input Stream was already disabled. The only thing i've done is rooted it. I don't get the message that it can't record wifi or voip calls like I did with other phones or before I switched to alsa in the settings.

13

1. Essentially, wifi calls are voip calls.

2. Android Audio System doesn't support voip call recording, this is why there is no call recording solution in the market for Skype, WhatsApp, Viber, WeChat, Hangouts, IMO, Facebook Messenger etc, even if you root the phone.

3. If a voip is working it occupies the "sound input device", as a result recorders will fail to record.

4. The Alsa engine in Boldbeast is very powerful. If Boldbeast is recording using the Alsa engine it occupies the "sound input device", as a result voip will fail to work.

To avoid the Alsa engine in Boldbeast to block wifi calls, please use Record Mode 1 suggested in post #1 to record calls, so that
- for a normal call Boldbeast works well.
- for a wifi call Boldbeast fails because of the reason described in 3 above (actually all recorders fail in this case).

14

When I use record mode 1 it sounds like everything is in slow motion or dragging. I can't understand what's being recorded but it doesn't interfere with wifi calls. I'm on project fi and during the day, when i'm at work, I don't have a cell signal so I use wifi for incoming and outgoing calls. With the incoming calls no one can hear my voice when I answer if I'm using boldbeast. I was hoping to be able to use it to automatically record calls but I can't and still use the wifi calling.

15

Badhabit_wb wrote:

When I use record mode 1 it sounds like everything is in slow motion or dragging.

This indicates the ROM has a little bug inside - it can't correctly resample the audio stream.
Boldbeast Recorder can bypass the bug. Please change the "Call Settings - File Sampling Rate" option in Boldbeast to 16000 to fix the problem.

16

Thanks. I just reset everything and tested at home. I think 16000 will work fine but I will test the other modes and see how they work. I also tried wifi calling and could answer incoming calls.  Seems to be working perfectly. Thanks for your help!

17

Glad to know it.

18

Seems to be working fine now. Thanks again for your help.

19 (edited by Badhabit_wb 2017-01-24 00:03:45)

Not sure what's going on now. I rebooted the phone and it won't record, correctly, unless I change it back to alsa. For some reason it's still blocking my microphone when I get an incoming call over WiFi but it doesn't block outgoing calls. For right now I will just manually turn it on for calls that I need to record but if there's any way to fix this issue I would appreciate it. Thank you.

20

Badhabit_wb wrote:

Not sure what's going on now. I rebooted the phone and it won't record, correctly

Please see the [001] part for the reasons and the solutions in this page http://www.boldbeast.com/android/call_r … oting.html
If the problem is still there please click the "Call Settings - Fix Recording Issues - Ask New Parameters" item in Boldbeast Recorder to send log files to me, let us have a look at them and see what happened.

21

Thanks I sent the info in.

22

I checked your log files:

When you used Alsa Mode,
- boldbeast recorded normal calls correctly.
- boldbeast recorded wifi calls correctly, but the caller couldn't hear your voice because the Alsa engine in boldbeast blocked wifi calls.

When you used Record Mode 1,
- boldbeast recorded normal calls correctly,.
- boldbeast failed to record wifi calls because wifi calls blocked boldbeast.

Everything worked exactly as expected.

23

Actually, when I used Alsa Mode,
- boldbeast recorded normal calls correctly.
- boldbeast recorded outgoing wifi calls correctly, no problem
- boldbeast recorded incoming wifi calls correctly, but the caller couldn't hear my voice because the Alsa engine in boldbeast blocked wifi calls.

Is there any way to keep it in auto mode and not block my voice on incoming wifi calls? It works fine with outgoing wifi calls.

24

Please change following settings:
- Call Settings - Incoming Calls - Auto Detect Answered State: No
- Call Settings - Incoming Calls - Auto Detect Max Time (Seconds): 15
- Call Settings - Incoming Calls - Restart Recording Upon Answered: No

I guess for an incoming wifi call if you answer the call within 15 seconds it works well, if you answer the call after 15 seconds the caller can't hear your voice. You can change 15 to another number as your will.

How about it?

25 (edited by johnb 2017-01-27 17:17:48)

Hi Boldbeast,

Query - the software works fine when using the google pixel phone without headphones, but will not record with headphones (it just picks up background noise).

Is there any known fix for this?

(Phone is not rooted)

Thanks,

John