1

I have the T-Mobile variant of the Moto Z2 Force, Model XT1789-04
Android 7.1.1

I am able to record good 2-way call audio with the following settings (without root)

- Record Mode: 1
- Tune Audio Effect: No
- Tune Audio Route: Disabled

2

Thank you for sharing the information.

3

Moto G6: Moto G6 call recorder
Moto G5S: Moto G5S call recorder
Moto G5: Moto G5 call recorder
Moto G4 Play: Moto G4 Play call recorder
Moto G4: Moto G 4th call recorder
Moto G3 Turbo Edition XT1556/7: Moto G Turbo Edition Call Recorder
Moto G3: Moto G 3rd Call Recorder
Moto G2, G1: Moto G call recorder
Moto Z2 Force: Moto Z2 Call Recorder
Moto Z Force / Moto Z Play: Moto Z Call Recorder
Moto X4: Moto X4 Call Recorder
Moto X Play XT1562: Moto X Play Call Recorder
Moto X Style XT1570/2/5: Moto X Style Call Recorder
Moto X Force XT1580/1: Moto X Force Call Recorder
Moto E4: Moto E4 Call Recorder
Moto E3: Moto E3 Call Recorder
Moto M: Moto M Call Recorder

4

With these setting Bluetooth calls record only my voice :(
Is there any solution for that?
I've tried all the possible record modes, but I didn't try the other options.
With setting can you recommend to record both ways on Bluetooth?

5

Please try to change "Tune Audio Route" to Group1, Group2 and Group3, test them one by one.
How about it?

6

boldbeast wrote:

Please try to change "Tune Audio Route" to Group1, Group2 and Group3, test them one by one.
How about it?

Unfortunately, the recording now doesn't work completely :(

Tried all Groups and Disabled :(

7

Even this one doesn't work :(

mainstain99 wrote:

I have the T-Mobile variant of the Moto Z2 Force, Model XT1789-04
Android 7.1.1

I am able to record good 2-way call audio with the following settings (without root)

- Record Mode: 1
- Tune Audio Effect: No
- Tune Audio Route: Disabled

8

You said "recording now doesn't work completely". All possibly reasons are described here:  http://www.boldbeast.com/android/call_r … oting.html , please see the [001] and [002] part.

9 (edited by justice_asbury 2018-01-21 06:53:13)

I own a Moto Z2 Force on T-Mobile and I have the latest 8.0 OS and the only way I get any good audio recording is with the speaker phone. Regular calls have good audio on my side but crummy audio on the other end. Bluetooth calls only records my end. I've tried all of the adjustments here but without success. Anyone have any ideas?

10

Please click "Set Default Settings" in Boldbeast Recorder, then test again.

11 (edited by justice_asbury 2018-01-22 02:19:54)

boldbeast wrote:

Please click "Set Default Settings" in Boldbeast Recorder, then test again.

As I stated earlier, I've read, re-read, and adjusted every possible setting. This includes simply, "Setting Default Settings" and retesting. I would not have said anything here without trying every possible option available here, at the trouble shooting page, and anywhere else I could find at least twice just to make sure I didn't get a false negative the first time.

Moto Z² Force / T-Mobile / non-root / 8.0 Android OS / fully updated

I should mention that it was only because of the trouble shooting page that anything at all is working. Disabling the "Ok Google" app completely and totally deleting "Moto Voice" has allowed me to record calls over speaker phone. Before that, I had nothing. If only I could get two-way call recording over Bluetooth, I'd be set. However, I've done everything short of Rooting I know of without success. I only get recordings of my voice without anyone else.

Help getting this problem fixed would be much appreciated.
Thanks

12

If you have clicked "Set Default Settings" and the problem is still there, this indicates:

- Android 7.0 works great, no root needed.
- Android 8.0 doesn't work well, no matter what recorder you are using in the market. So you should root the phone, then Boldbeast Recorder can fix it perfectly with or without bluetooth connected, with or without the speaker switched on.