1

Samsung Galaxy Note8 doesn't need root, it records calls loudly and clearly in two sides.
Please use following settings to record calls:

- Record Mode: 1
- Record Format: MP3
- Tune Audio Effect: No
- Tune Audio Route: Group3
- Tune Samsung1: Yes
- Tune Samsung2: Yes
- Tune Samsung3: No


Bluetooth Recording
================
Galaxy Note8 bluetooth recording works perfectly.


Wifi Call Recording
================
If you enabled the "wifi call" feature in your Galaxy Note8 you'll find "some calls were not recorded, it seems the recorder is unreliable". In fact, on the contrary, the recorder is super reliable. You should know the fact - wifi calls can't be recorded, no matter what recorder you are using in the market. This is limited by the ROM.

So please disable the "wifi call" feature in your phone, then all your calls will be reliably and perfectly recorded.


Fake call
================
After upgrading to Android 8.0 some Galaxy Note8 users met this problem - If you accidentally tap on a phone number in the Contacts app without clicking the dial icon, the ROM at once wrongly notify the recorder "a new call is ongoing" so the recorder begins to show the in-call button or begins to record the fake call.

Obviously this is a bug in the ROM, no matter what recorder in the market you are using the problem will always be there. Boldbeast Recorder can perfectly bypass the bug. Please enable the "Call Settings - Outgoing Calls - Ongoing Upon Offhook" option in Boldbeast, then Boldbeast can detect "this is a fake call" so it will correctly ignore it.

2

Galaxy S9 / S9 Plus: Galaxy S9 / S9 Plus Call Recorder
Galaxy S8 / S8 Plus: Galaxy S8 / S8 Plus Call Recorder
Galaxy S7 / S7 Edge: Galaxy S7 / S7 Edge Call Recorder
Galaxy S6 / S6 Edge: Galaxy S6 / S6 Edge Call Recorder
Galaxy S5: Galaxy S5 Call Recorder
Galaxy S5 mini: Galaxy S5 mini Call Recorder

Galaxy Note9: Galaxy Note9 Call Recorder
Galaxy Note8: Galaxy Note8 Call Recorder
Galaxy Note7: Galaxy Note7 Call Recorder
Galaxy Note5: Galaxy Note5 Call Recorder
Galaxy Note4: Galaxy Note4 Call Recorder

Galaxy A9: Galaxy A9 Call Recorder
Galaxy A8: Galaxy A8 Call Recorder
Galaxy A7: Galaxy A7 Call Recorder
Galaxy J7: Galaxy J7 Call Recorder
Galaxy J5: Galaxy J5 Call Recorder

3 (edited by hatem0 2017-09-28 15:03:27)

I am sorry to inform you that it is not working on my Note8 OS 7.1.1,  boldbeast V9.9, Mode1, 4, 5
It doesn't record all the calls and whrn it records it skip the first 5sec of the conversation.
Although the Note8 comes with call recorder built-in in the contacts settings but I prefer to use the Boldbeast app.
Please try to find a solution.

4

hatem0 wrote:

I am sorry to inform you

it is not working on my Note8 OS 7.1.1,  boldbeast V9.9, Mode1, 4, 5
=> Please update Boldbeast in your phone to V10.2, it works at once.

It doesn't record all the calls
=> All calls will be recorded, it's very stable. Fix the problem this way: see the [002] part in this page http://www.boldbeast.com/android/call_r … oting.html

and when it records it skip the first 5sec of the conversation.
=> You can tune the time yourself. Fix the problem this way: see the [005] part in this page http://www.boldbeast.com/android/call_r … oting.html

5 (edited by hatem0 2017-10-09 15:44:41)

Dear Boldbeast developer

I upgraded the app to the latest version 10.0 GP but still not working.
I don't know why it is working with everybody smoothly except with me. Is it because I have a Korean version SM-N950N
I added the app to the battery optimization unmonitored apps.
I turned off and on the phone
I activated the standby indicator
But still not working.

I made now two calls, 1st call last 1m 59s, the app recorded only 1m 29s and without detecting the information. (showing 0000000 and unknown instead of the number and the name).
2nd call last 1m 3s, the app didn't record the call

is there any solution?

6

hatem0 wrote:

I made now two calls, 1st call last 1m 59s, the app recorded only 1m 29s and without detecting the information. (showing 0000000 and unknown instead of the number and the name). 2nd call last 1m 3s, the app didn't record the call

1st call last 1m 59s, the app recorded only 1m 29s
=> You can tune the time yourself. Please see the [005] part in this page http://www.boldbeast.com/android/call_r … oting.html

and without detecting the information. (showing 0000000 and unknown instead of the number and the name).
=> About the telephone number and contact name problem, see here: http://www.boldbeast.com/forum/topic116 … -name.html

2nd call last 1m 3s, the app didn't record the call
=> Please check the "Call Settings - Auto Record Calls - Rule to Auto Record Calls" option in the app, make sure you have set it correctly.

7 (edited by flam 2017-10-19 23:25:56)

Hello, thank you for your app, it worked flawlessly on my BlackBerry Priv, and so I've started to use it on my note 8 (paid edition).

I have followed your setup instructions in this thread, and it works exactly as it should.

However, I want to engage with Bixby at some point and am wondering if it will work then.

Does boldbeast work if bixby is on?

(for info, I am in Australia, using the Australian version of the Note 8, which means that it is factory unlocked and unbranded))

8

Bixby is a voice assistant app made by Samsung, when it is working it occupies the microphone to pick up sound to recognize your "voice command", this blocks other recorder doing its job.

If you enable Bixby in your phone you will find:
- some calls were recorded successfully, because at that specific time Bixby was not working
- some calls could not be recorded, because at that specific time Bixby was working

No matter what recorder in the market you are using the result is the same. To avoid this "some calls recorded some calls not" problem please disable Bixby. By the way OK Google is another voice assistant app made by Google, for the same reason you should disable OK Google also. For more information please see the [001] part in this page http://www.boldbeast.com/android/call_r … oting.html

9

Hi, for my note 8, it keeps on showing a dialogue "Cannot record calls. Android allows only one recorder working, so at first you MUST remove or force stop ALL other recorders in your phone, otherwise this app will surely fail to record calls because of conflicts."

How to fix it?

10

roederer wrote:

it keeps on showing a dialogue "Cannot record calls. Android allows only one recorder working, so at first you MUST remove or force stop ALL other recorders in your phone, otherwise this app will surely fail to record calls because of conflicts."

Please
1. Remove all other recorders.
2. Disable "OK Google".
3. Disable "Bixby".
Then it works at once. Why? See the [001] part in this page http://www.boldbeast.com/android/call_r … oting.html

11

boldbeast wrote:
roederer wrote:

it keeps on showing a dialogue "Cannot record calls. Android allows only one recorder working, so at first you MUST remove or force stop ALL other recorders in your phone, otherwise this app will surely fail to record calls because of conflicts."

Please
1. Remove all other recorders.
2. Disable "OK Google".
3. Disable "Bixby".
Then it works at once. Why? See the [001] part in this page http://www.boldbeast.com/android/call_r … oting.html

Thanks, it can record now, but always missing the first 2-3 seconds of recording, any way to solve it?

12

roederer wrote:

Thanks, it can record now, but always missing the first 2-3 seconds of recording, any way to solve it?

Please see [005] in this page http://www.boldbeast.com/android/call_r … oting.html

13

boldbeast wrote:
roederer wrote:

Thanks, it can record now, but always missing the first 2-3 seconds of recording, any way to solve it?

Please see [005] in this page http://www.boldbeast.com/android/call_r … oting.html

I set the

Outgoing call>>Auto Detect Max Time>> 1

Incoming call>>Auto Detect Max Time>>30

I still happened, both outgoing and incoming call....

14

Can you please click "Call Settings - Fix Recording Issues - Ask New Parameters" in Boldbeast Recorder to send log files to me? Let me have a look at them and see what happened in your phone. Thanks.

15

Please update Boldbeast Recorder in your phone to the latest version V10.8, we have optimized the record engine, now the "delay several seconds" problem has fixed. Further more we have tuned recording parameters in V10.8 for Galaxy Note8, now it's super stable, it works pretty smooth.

16

thank you for the great hard job you put in this app
iam in day 5 of testing the app and its working very well on my note8 Exyanos version and recording the calls in crystal clear sound.
there is an annoying issue i faced, the surrounded sounds will be recorded along with the call. is there any way or setup option to isolate the recording for the call only regardless the surrounded sounds?
iam waiting to solve this to buy my full copy.
thank you

boldbeast wrote:

Samsung Galaxy Note8 doesn't need root, it records calls loudly and clearly in two sides.
Please use following settings to record calls:

- Record Mode: 1
- Record Format: MP3
- Tune Audio Effect: No
- Tune Audio Route: Group3
- Tune Samsung1: Yes
- Tune Samsung2: Yes
- Tune Samsung3: No



Bluetooth Recording
================
Note8 bluetooth recording works perfectly.

17

The app records both the caller's voice and your own voice in recordings. The caller's voice is from the wireless signal, your voice is from the microphone. The microphone picks up your voice and the surrounded sounds.

Some phones have options like "Noise Suppress", "Echo Cancel", "Microphone Enhancement" or something similar to suppress surrounded sounds, please check settings in your phone and try to change them if any.

18

thank you for reply
no such settings options or MIC options in note 8, are there such options in the app itself or can you help me to find external tool to do it ?

thank you

boldbeast wrote:

The app records both the caller's voice and your own voice in recordings. The caller's voice is from the wireless signal, your voice is from the microphone. The microphone picks up your voice and the surrounded sounds.

Some phones have options like "Noise Suppress", "Echo Cancel", "Microphone Enhancement" or something similar to suppress surrounded sounds, please check settings in your phone and try to change them if any.

19

Boldbeast Recorder doesn't have these settings inside, because they are provided by the phone, and they are different from phone to phone.

In some phones open the Dialer app, click the Menu key, it will show settings, please check if there are such options.

20

Samsung product is always better as compare to other all recorder is also best.

21

Hi Boldbeast
I have the pro version but have an issue

When i make a call, both sides are recorded, but if i receive a call only my side is recorded
Could you please advice a solution, thanks

Regards
Poul

22

Polleman3165 wrote:

When i make a call, both sides are recorded, but if i receive a call only my side is recorded

Some phones in the market do have this issue, but Galaxy Note8 don't have. So far there is no Note8 user reported this problem. Are you using Galaxy Note8?

Anyway this issue can be fixed easily. Please change following settings in Boldbeast Recorder:
- Call Settings - Incoming Calls - Auto Detect Answered State: Yes
- Call Settings - Incoming Calls - Auto Detect Max Time (Seconds): 100
- Call Settings - Incoming Calls - Restart Recording Upon Answered: No
Then the issue will disappear.

23

How can i start call recording in my mobile note 8

24

ankush.jamesbond wrote:

How can i start call recording in my mobile note 8

Manually start recording
During a call Boldbeast Recorder will display a small button on the screen, you can manually click it to start recording.

Automatically start recording (pro version)
When a new call arises Boldbeast Recorder will Automatically start recording.